Edraw Support Center

Get quick answers and step-by-step instructions in our support center.

Save Documents

When you save an unnamed file, you can save it into a folder on your hard disk drive, the desktop, or another storage location. You need to find the target location in the Save in list. Besides, the saving process is the same no matter what location you choose.

Go to the File tab > Save as or press Ctrl + S. You can choose whether to save the documents in your computer or cloud through the Save as option.

file save as option

File Recovery

File Recovery is not a replacement for regularly saving your files. If you choose not to save the recovered file after you open it, the file will be deleted. If you save the recovered file, it will replace the original file (unless you specify a new file name for it).

The more frequently your files are saved, the more information will be recovered if there is a power failure or emergency that may cause losing diagrams.

Go to the View tab, click the File Recovery button to open File Recovery window where you can see all the available backup files.

Navigate to File > Options > General to set a time interval of saving auto-recovered files.

file auto recover option

Watch this video to learn more. If the video doesn't play, please visit it at YouTube.

Timestamps
00:09 Create a new drawing document
00:39 Add multiple pages in one document
00:47 Choose and open a template example
00:59 To open *.eddx EdrawMax file
01:10 Save drawing files to local device and on personal Cloud
01:43 Import *VSDX Visio file into EdrawMax
02:00 Import SVG file into EdrawMax
02:17 Eport EdrawMax files to PNG, JPG, TIF and so on graphic files
02:42 Eport EdrawMax files to PDF, PS and EPS format
03:05 Export EdrawMax to editable MS Word, PPT and Excel
03:30 Export EdrawMax to HTML
03:52 Export EdrawMax to SVG file
04:04 Export EdrawMax to *vsdx Visio file
04:19 Print EdrawMax drawings